Run| Workspace| Log| Issues| Fixes| Pre-reqs| Stats| XRef| Maven Repository Proxy Log Gump Logo

Details

Parameters

Prefix Name Value
-D java.awt.headless true
-D build.sysclasspath only
-X bootclasspath/p :/srv/gump/public/workspace/xml-xerces2/build/xercesImpl.jar /srv/gump/public/workspace/xml-commons/java/external/build/xml-apis.jar
org.apache.tools.ant.Main
-D gump.merge /srv/gump/public/gump/work/merge.xml
-D compile.source 1.5
-D compile.target 1.5
-D junit.home /srv/gump/public/workspace/junit
-D component.version 20180116
jar

Environment Overrides

Name Value
CLASSPATH :/usr/lib/jvm/java-8-oracle/lib/tools.jar /srv/gump/public/workspace/apache-commons/beanutils/target/classes /srv/gump/public/workspace/ant/dist/lib/ant.jar /srv/gump/public/workspace/ant/dist/lib/ant-launcher.jar /srv/gump/public/workspace/ant/dist/lib/ant-jmf.jar /srv/gump/public/workspace/ant/dist/lib/ant-junit.jar /srv/gump/public/workspace/ant/dist/lib/ant-junit4.jar /srv/gump/public/workspace/ant/dist/lib/ant-swing.jar /srv/gump/public/workspace/ant/dist/lib/ant-apache-resolver.jar /srv/gump/public/workspace/ant/dist/lib/ant-apache-xalan2.jar /srv/gump/public/workspace/xml-commons/java/build/resolver.jar /srv/gump/public/workspace/xml-commons/java/external/build/xml-apis-ext.jar /srv/gump/public/workspace/apache-commons/logging/target/commons-logging-20180116.jar /srv/gump/public/workspace/apache-commons/logging/target/commons-logging-api-20180116.jar /srv/gump/packages/commons-collections3/commons-collections-3.2.1.jar /srv/gump/public/workspace/junit/target/junit-4.13-SNAPSHOT.jar

Command Line

/usr/lib/jvm/java-8-oracle/bin/java -Djava.awt.headless=true
        -Dbuild.sysclasspath=only
        -Xbootclasspath/p:/srv/gump/public/workspace/xml-xerces2/build/xercesImpl.jar:/srv/gump/public/workspace/xml-commons/java/external/build/xml-apis.jar
        org.apache.tools.ant.Main -Dgump.merge=/srv/gump/public/gump/work/merge.xml
        -Dcompile.source=1.5 -Dcompile.target=1.5
        -Djunit.home=/srv/gump/public/workspace/junit -Dcomponent.version=20180116 jar 

Output

Buildfile: /srv/gump/public/workspace/apache-commons/beanutils/build.xml

init:
     [echo] -------- beanutils 20180116 --------

prepare:
    [mkdir] Created dir: /srv/gump/public/workspace/apache-commons/beanutils/target
    [mkdir] Created dir: /srv/gump/public/workspace/apache-commons/beanutils/target/classes
    [mkdir] Created dir: /srv/gump/public/workspace/apache-commons/beanutils/target/conf
    [mkdir] Created dir: /srv/gump/public/workspace/apache-commons/beanutils/target/tests

compile:
    [javac] Compiling 111 source files to /srv/gump/public/workspace/apache-commons/beanutils/target/classes
    [javac] warning: [options] source value 1.5 is obsolete and will be removed in a future release
    [javac] warning: [options] target value 1.5 is obsolete and will be removed in a future release
    [javac] warning: [options] To suppress warnings about obsolete options, use -Xlint:-options.
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/BaseDynaBeanMapDecorator.java:169: error: diamond operator is not supported in -source 1.5
    [javac]         final Set<Map.Entry<K, Object>> set = new HashSet<>(properties.length);
    [javac]                                                           ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/BasicDynaBean.java:76: error: diamond operator is not supported in -source 1.5
    [javac]     protected HashMap<String, Object> values = new HashMap<>();
    [javac]                                                            ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/BasicDynaClass.java:142: error: diamond operator is not supported in -source 1.5
    [javac]     protected HashMap<String, DynaProperty> propertiesMap = new HashMap<>();
    [javac]                                                                         ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/BeanIntrospectionData.java:142: error: diamond operator is not supported in -source 1.5
    [javac]         final Map<String, String> methods = new HashMap<>();
    [javac]                                                         ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/BeanMap.java:52: error: diamond operator is not supported in -source 1.5
    [javac]     private transient HashMap<String, Method> readMethods = new HashMap<>();
    [javac]                                                                         ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/BeanUtils.java:477: error: diamond operator is not supported in -source 1.5
    [javac]         return new WeakFastHashMap<>();
    [javac]                                    ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/BeanUtilsBean.java:491: error: diamond operator is not supported in -source 1.5
    [javac]             return (new java.util.HashMap<>());
    [javac]                                           ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/ContextClassLoaderLocal.java:106: error: diamond operator is not supported in -source 1.5
    [javac]     private final Map<ClassLoader, T> valueByClassLoader = new WeakHashMap<>();
    [javac]                                                                            ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/ConvertUtilsBean.java:149: error: diamond operator is not supported in -source 1.5
    [javac]             new WeakFastHashMap<>();
    [javac]                                 ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/DefaultIntrospectionContext.java:57: error: diamond operator is not supported in -source 1.5
    [javac]         descriptors = new HashMap<>();
    [javac]                                   ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/JDBCDynaClass.java:67: error: diamond operator is not supported in -source 1.5
    [javac]     protected Map<String, DynaProperty> propertiesMap = new HashMap<>();
    [javac]                                                                     ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/LazyDynaBean.java:881: error: diamond operator is not supported in -source 1.5
    [javac]         return new ArrayList<>();
    [javac]                              ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/MappedPropertyDescriptor.java:436: error: diamond operator is not supported in -source 1.5
    [javac]                 methodRef = new SoftReference<>(m);
    [javac]                                               ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/MethodUtils.java:1297: error: diamond operator is not supported in -source 1.5
    [javac]                 cache.put(md, new WeakReference<>(method));
    [javac]                                                 ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/PropertyUtilsBean.java:130: error: diamond operator is not supported in -source 1.5
    [javac]         descriptorsCache = new WeakFastHashMap<>();
    [javac]                                                ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/RowSetDynaClass.java:85: error: diamond operator is not supported in -source 1.5
    [javac]     protected List<DynaBean> rows = new ArrayList<>();
    [javac]                                                   ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/SuppressPropertiesBeanIntrospector.java:68: error: diamond operator is not supported in -source 1.5
    [javac]         propertyNames = Collections.unmodifiableSet(new HashSet<>(
    [javac]                                                                 ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/WeakFastHashMap.java:419: error: diamond operator is not supported in -source 1.5
    [javac]             results = new WeakFastHashMap<>(map);
    [javac]                                           ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/WrapDynaClass.java:109: error: diamond operator is not supported in -source 1.5
    [javac]     protected HashMap<String, PropertyDescriptor> descriptorsMap = new HashMap<>();
    [javac]                                                                                ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/converters/AbstractArrayConverter.java:190: error: diamond operator is not supported in -source 1.5
    [javac]             final List<String> list = new ArrayList<>();
    [javac]                                                     ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] /srv/gump/public/workspace/apache-commons/beanutils/src/main/java/org/apache/commons/beanutils2/converters/ArrayConverter.java:365: error: diamond operator is not supported in -source 1.5
    [javac]             final List<Object> list = new ArrayList<>(1);
    [javac]                                                     ^
    [javac]   (use -source 7 or higher to enable diamond operator)
    [javac] 21 errors
    [javac] 3 warnings

BUILD FAILED
/srv/gump/public/workspace/apache-commons/beanutils/build.xml:151: Compile failed; see the compiler error output for details.

Total time: 1 second

Apache Gump, Gump, Apache, the Apache feather logo, and the Apache Gump project logos are trademarks of The Apache Software Foundation.

Last Updated: Tue, 16 Jan 2018 12:00:07 ().Python Logo